Skip to content
Not rated

CVE-2021-37404 There is a potential heap buffer overflow in Apache Hadoop libhdfs native code

Description

There is a potential heap buffer overflow in Apache Hadoop libhdfs native code. Opening a file path provided by user without validation may result in a denial of service or arbitrary code execution. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.

Affected products and versions

Product Affected versions Fixed in
Apache Hadoop Versions not published

References

Timeline

  1. Published
  2. Last modified
The 18 CVEs of Apache Hadoop →
Track this CVE