Skip to content
4.7 Medium

CVE-2020-15242 Next.js versions >=9.5.0 and <9.5.4 are vulnerable to an Open Redirect

Description

Next.js versions >=9.5.0 and <9.5.4 are vulnerable to an Open Redirect. Specially encoded paths could be used with the trailing slash redirect to allow an open redirect to occur to an external site. In general, this redirect does not directly harm users although can allow for phishing attacks by redirecting to an attackers domain from a trusted domain. The issue is fixed in version 9.5.4.

Affected products and versions

Product Affected versions Fixed in
next.js 9.5 9.5.0 → < 9.5.4 9.5.4

References

Timeline

  1. Published
  2. Last modified
The 57 CVEs of next.js →
Track this CVE